VCSA Upgrade: Failed to authenticate with the guest operating system using the supplied credentials.

Problem: During an upgrade from VCSA 6.5 to 6.7, the following error was observed in the install log and prevented stage one of the upgrade from starting.

  • error: sourcePrecheck: error in getting source Info: ServerFaultCode: Failed to authenticate with the guest operating system using the supplied credentials.

The root password entered into the wizard worked for logging into the appliance via the web interface (https://vcsa-ip:5480/) as well as via SSH.

Attempting to change the password or disable password expiration via the web interface did not work.

Solution: I was able to reset the password via SSH using the follow commands. Once done the wizard accepted the password and was able to complete stage 1 of the upgrade.

screencap1

Success!

screencap2

2 thoughts on “VCSA Upgrade: Failed to authenticate with the guest operating system using the supplied credentials.

  1. 2019-09-04T18:27:28.892Z – info: VM Identifier for Source VC: 22
    2019-09-04T18:27:29.032Z – debug: initiateFileTransferFromGuest error: ServerFaultCode: Failed to authenticate with the guest operating system using the supplied credentials.
    2019-09-04T18:27:29.032Z – debug: Failed to get fileTransferInfo:ServerFaultCode: Failed to authenticate with the guest operating system using the supplied credentials.
    2019-09-04T18:27:29.032Z – debug: Failed to get url of file in guest vm:ServerFaultCode: Failed to authenticate with the guest operating system using the supplied credentials.
    2019-09-04T18:27:29.032Z – error: Error in getting fileData for nodeType. Error: ServerFaultCode: Failed to authenticate with the guest operating system using the supplied credentials.
    2019-09-04T18:27:29.032Z – error: Failed to read the nodetype, Error: Failed to authenticate with the guest operating system using the supplied credentials.
    2019-09-04T18:27:29.032Z – info: Checking if password expired
    2019-09-04T18:27:30.676Z – info: Banner from server,
    VMware vCenter Server Appliance 6.5.0.10000

    I get this error fro log file during upgrade the vCenter Server or Platform Services Controller please help me sir.

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s